<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
    <title>Here’s A Lovely Custom Royal Enfield Interceptor 650 From Thailand</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://gaadiwaadi.com/wp-content/cache/min/1/af07065d0eab9e6ec615a5c0bfb88fc7.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" />
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-76.png"><link rel="apple-touch-icon" sizes="76x76" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-76.png"/><link rel="apple-touch-icon" sizes="120x120" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-120.png"/><link rel="apple-touch-icon" sizes="152x152" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-152.png"/><link rel="apple-touch-icon" sizes="114x114" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-114.png"/><link rel="apple-touch-icon" sizes="144x144" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-144.png"/>
	<!-- This site is optimized with the Yoast SEO Premium plugin v17.7 (Yoast SEO v17.8) - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Thailand-based Apollo Garage recently shared pictures of a modified RE Interceptor online, and the bike looks undeniably marvellous" />
	<link rel="canonical" href="https://gaadiwaadi.com/?p=191492" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Here’s A Lovely Custom Royal Enfield Interceptor 650 From Thailand" />
	<meta property="og:description" content="Thailand-based Apollo Garage recently shared pictures of a modified RE Interceptor online, and the bike looks undeniably marvellous" />
	<meta property="og:url" content="https://gaadiwaadi.com/?p=191492" />
	<meta property="og:site_name" content="Gaadiwaadi.com - Latest Car &amp; Bike News" />
	<meta property="article:publisher" content="https://www.facebook.com/gaadiwaadi" />
	<meta property="article:author" content="https://www.facebook.com/kshitij.rawat1/" />
	<meta property="article:published_time" content="2021-12-20T13:12:39+00:00" />
	<meta property="og:image" content="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1.jpg" />
	<meta property="og:image:width" content="1600" />
	<meta property="og:image:height" content="902" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@gaadiwaadi" />
	<meta name="twitter:site" content="@gaadiwaadi" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Kshitij Rawat" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<!-- / Yoast SEO Premium plugin. -->


<link rel="amphtml" href="https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/amp/" /><meta name="generator" content="AMP for WP 1.0.77.33"/><link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Gaadiwaadi.com - Latest Car &amp; Bike News &raquo; Feed" href="https://gaadiwaadi.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gaadiwaadi.com - Latest Car &amp; Bike News &raquo; Comments Feed" href="https://gaadiwaadi.com/comments/feed/" />
<!-- gaadiwaadi.com is managing ads with Advanced Ads – https://wpadvancedads.com/ --><!--noptimize--><script id="gaadi-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<!--/noptimize--><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>







<link rel='preload'   href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=11' data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />

<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>



<script type='text/javascript' id='append_link-js-extra'>
/* <![CDATA[ */
var append_link = {"read_more":"Read more at: %link%","prepend_break":"2","use_title":"false","add_site_name":"true","site_name":"Gaadiwaadi.com - Latest Car & Bike News","site_url":"https:\/\/gaadiwaadi.com","always_link_site":"false"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/cache/min/1/wp-content/plugins/append-link-on-copy/js/append_link.js?ver=1639849454' id='append_link-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/plugins/wp-next-post/inc/../assets/js/owl.carousel.min.js?ver=5.8.2' id='next-post-owl-js-js' defer></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.30.5' id='advanced-ads-advanced-js-js' defer></script>

<!-- Google Analytics snippet added by Site Kit -->
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-49260806-1' id='google_gtagjs-js' async></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["gaadiwaadi.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-49260806-1", {"anonymize_ip":true});
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<link rel="https://api.w.org/" href="https://gaadiwaadi.com/wp-json/" /><link rel="alternate" type="application/json" href="https://gaadiwaadi.com/wp-json/wp/v2/posts/191492" /><meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://gaadiwaadi.com/?p=191492' />
<link rel="alternate" type="application/json+oembed" href="https://gaadiwaadi.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgaadiwaadi.com%2Fheres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://gaadiwaadi.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgaadiwaadi.com%2Fheres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand%2F&#038;format=xml" />
<!-- Start Alexa Certify Javascript -->
<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
_atrk_opts = { atrk_acct:"faY2n1aMp410WR", domain:"gaadiwaadi.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=faY2n1aMp410WR" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->  <meta name="generator" content="Site Kit by Google 1.47.0" />			<style type="text/css">
				.svc_pre_container_after .svc_next_content{display:none;}
.svc_pre_container_after .svc_next_ref::before{border-top: 10px solid #000;}
.svc_pre_container_after .svc_next_ref{border-top: 4px solid #000;}					.svc_next_content{ text-align:center;}
								.svc_infinite_container.svc_next_artical_div .td-post-next-prev{display:none; !important;}
								.svc_infinite_container.svc_next_artical_div .author-box-wrap{display:none; !important;}
								.svc_infinite_container.svc_next_artical_div .td_block_related_posts{display:none; !important;}
								.svc_infinite_container.svc_next_artical_div #comments{display:none; !important;}
							</style>
			<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<style type='text/css'>img#wpstats{display:none}</style>
		<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script type="rocketlazyloadscript">
        window.tdb_globals = {"wpRestNonce":"16211a832b","wpRestUrl":"https:\/\/gaadiwaadi.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script type="rocketlazyloadscript">
				window.tdwGlobal = {"adminUrl":"https:\/\/gaadiwaadi.com\/wp-admin\/","wpRestNonce":"16211a832b","wpRestUrl":"https:\/\/gaadiwaadi.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			    <script type="rocketlazyloadscript">
        window.tdaGlobal = {"adminUrl":"https:\/\/gaadiwaadi.com\/wp-admin\/","wpRestNonce":"16211a832b","wpRestUrl":"https:\/\/gaadiwaadi.com\/wp-json\/","permalinkStructure":"\/%postname%\/","postId":191492};
    </script>
    
<!-- Schema & Structured Data For WP v1.9.92 - -->
<script type="application/ld+json" class="saswp-schema-markup-output">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</script>

      <meta name="onesignal" content="wordpress-plugin"/>
            <script type="rocketlazyloadscript">

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://gaadiwaadi.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'dfa9a29a-11ef-4dff-9448-6ad27c7e6941';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://gaadiwaadi.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "Web ID web.onesignal.auto.47c70ae7-2660-4f5d-88d3-857f7dfd7254";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<!-- JS generated by theme -->

<script type="rocketlazyloadscript">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</script>


<!-- Header style compiled by theme -->

<style>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</style>




<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://gaadiwaadi.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://gaadiwaadi.com/bikes-news/",
                    "name": "Bikes News"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/",
                    "name": "Here’s A Lovely Custom Royal Enfield Interceptor 650 From Thailand"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-152-100x100.png" sizes="32x32" />
<link rel="icon" href="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-152.png" sizes="192x192" />
<meta name="msapplication-TileImage" content="https://gaadiwaadi.com/wp-content/uploads/2015/05/Gaadiwaadi-Favicon-152.png" />
		<style type="text/css" id="wp-custom-css">
			.td-container, .tdc-row {
		width: 970px ; 
	}
	.amp-single .amp-author, .amp-single #pagination,.amp-single .cmts{

	display: none !important;
	}.sp-rt .amp-author{	display: none !important;}
	body.td-animation-stack-type0 .td-animation-stack .entry-thumb, body.td-animation-stack-type0 .post img{
		opacity: 1;}
		@media(max-width:991px){

		.td-container, .tdc-row {
		   width:100% !important;
		   }
	}
body .fluid-width-video-wrapper iframe, body  .fluid-width-video-wrapper object, body  .fluid-width-video-wrapper embed {
	position: unset !important;
}		</style>
		
<!-- Button style compiled by theme -->

<style>
    
</style>

	<style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript">
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="post-template-default single single-post postid-191492 single-format-standard td-standard-pack heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand global-block-template-1 aa-prefix-gaadi- td-full-layout"  >

    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/gaadiwaaditimes" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://news.google.com/publications/CAAqBwgKMLyt3gowkeLVAQ?oc=3&ceid=IN:en" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://news.google.com/publications/CAAqBwgKMLyt3gowkeLVAQ?oc=3&ceid=IN:en" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/gaadiwaadidotcom" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-14906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-14906"><a href="https://gaadiwaadi.com/cars-news/">Cars News</a></li>
<li id="menu-item-14907" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14907"><a href="https://gaadiwaadi.com/bikes-news/">Bikes News</a></li>
<li id="menu-item-128735" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-128735"><a href="https://gaadiwaadi.com/auto-industry-news/">Auto Industry News</a></li>
<li id="menu-item-128737" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-128737"><a href="https://gaadiwaadi.com/modified-cars-bikes/">Mod Job</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://gaadiwaadi.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style multipurpose 1
-->


<div class="td-header-wrap tdm-header tdm-header-style-1 ">
    
    
    <div class="td-header-menu-wrap-full td-container-wrap ">
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
            <div class="td-container td-header-row td-header-main-menu">
                <div class="tdm-menu-btns-socials">
            <div class="header-search-wrap">
            <div class="td-search-btns-wrap">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" aria-label="Search" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>

            <div class="td-drop-down-search">
                <form method="get" class="td-search-form" action="https://gaadiwaadi.com/">
                    <div role="search" class="td-head-form-search-wrap">
                        <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                    </div>
                </form>
                <div id="td-aj-search"></div>
            </div>
        </div>
    
    
    </div>

<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#" aria-label="mobile-toggle"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-disable" href="https://gaadiwaadi.com/">
			<img src="https://gaadiwaadi.com/wp-content/uploads/2018/06/GW-logo.png" alt="Gaadiwaadi-logo" width="300" height="89"/>
		</a>
				<a class="td-header-logo td-sticky-disable" href="https://gaadiwaadi.com/">
				<img src="https://gaadiwaadi.com/wp-content/uploads/2018/06/GW-logo.png" alt="Gaadiwaadi-logo" width="300" height="89"/>
				<span class="td-visual-hidden">Gaadiwaadi.com &#8211; Latest Car &amp; Bike News</span>
			</a>
		    </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-14906"><a href="https://gaadiwaadi.com/cars-news/">Cars News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-14907"><a href="https://gaadiwaadi.com/bikes-news/">Bikes News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-128735"><a href="https://gaadiwaadi.com/auto-industry-news/">Auto Industry News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-128737"><a href="https://gaadiwaadi.com/modified-cars-bikes/">Mod Job</a></li>
</ul></div></div>
            </div>
        </div>
    </div>

    </div>
            </div>

            
    <div class="td-main-content-wrap td-container-wrap">

        <div class="td-container td-post-template-default ">
            <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://gaadiwaadi.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Bikes News" class="entry-crumb" href="https://gaadiwaadi.com/bikes-news/">Bikes News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Here’s A Lovely Custom Royal Enfield Interceptor 650 From Thailand</span></div></div>

            <div class="td-pb-row">
                                        <div class="td-pb-span12 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-191492" class="post-191492 post type-post status-publish format-standard has-post-thumbnail category-bikes-news category-international-auto-news category-modified-cars-bikes category-royal-enfield"  47>
        <div class="td-post-header">

            <!-- category -->
            <header class="td-post-title">
                <h1 class="entry-title">Here’s A Lovely Custom Royal Enfield Interceptor 650 From Thailand</h1>
                

                <div class="td-module-meta-info">
                    <!-- author --><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://gaadiwaadi.com/author/ksitijrawat20/">Kshitij Rawat</a><div class="td-author-line"> - </div> </div>                    <!-- date --><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-12-20T18:42:39+05:30" >December 20, 2021</time></span>                    <!-- comments -->                    <!-- views -->                </div>

            </header>

        </div>

        
        <div class="td-post-content tagdiv-type">
            <!-- image --><div class="td-post-featured-image"><img width="1068" height="602" class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201068%20602'%3E%3C/svg%3E" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-696x392.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1.jpg 1600w" data-lazy-sizes="(max-width: 1068px) 100vw, 1068px" alt="Royal Enfield Interceptor 650 custom Apollo Garage img1" title="Royal Enfield Interceptor 650 custom Apollo Garage img1" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1068x602.jpg"/><noscript><img width="1068" height="602" class="entry-thumb" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1068x602.jpg" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-696x392.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1.jpg 1600w" sizes="(max-width: 1068px) 100vw, 1068px" alt="Royal Enfield Interceptor 650 custom Apollo Garage img1" title="Royal Enfield Interceptor 650 custom Apollo Garage img1"/></noscript></div>
            <!-- content -->
 <!-- A generated by theme --> 

<script type="rocketlazyloadscript" async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_top tdi_1 td_block_template_1 ">

<style>
/* custom css */
.tdi_1.td-a-rec{
					text-align: center;
				}.tdi_1 .td-element-style{
					z-index: -1;
				}.tdi_1.td-a-rec-img{
				    text-align: left;
				}.tdi_1.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
var td_screen_width = window.innerWidth;
</script>
<noscript id="td-ad-placeholder"></noscript></div>

 <!-- end A --> 

<div class="gaadi-before-content_2" style="float: left; margin-top: 5px; margin-right: 10px; margin-bottom: 5px; width: 336px; height: 280px; " id="gaadi-1051148579"><script type="rocketlazyloadscript" async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-9822732038633821" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" 
data-ad-client="ca-pub-9822732038633821" 
data-ad-slot="3201228586"></ins> 
<script type="rocketlazyloadscript"> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><h2>Thailand-based Apollo Garage recently shared pictures of a modified RE Interceptor online, and the bike looks undeniably marvellous</h2>
<p>Royal Enfield Interceptor 650 was launched back in 2018, alongside the Continental GT650, and the motorcycle was an instant hit in India. The manufacturer then introduced it to various international markets, where it saw a lot of success as well. RE’s 650 twins are extremely popular in South Asian and European markets.</p>
<p>Royal Enfield motorcycles have always been the top pick for custom-built projects in India. Well, the brand has been gaining momentum in the aftermarket circles overseas as well! We’ve come across plenty of modified Royal Enfield bikes online, which have been built overseas, and most of these have make our hearts skip a beat.</p>
<p>Here, we have featured another custom-built Royal Enfield Interceptor 650, which has been built by <strong>Apollo Garage</strong> of Thailand. The motorcycle sports a lot of extensive changes, with an overall dark and stealthy look. As per the owner’s wish, the motorcycle has been given a dark colour scheme; the tank and side panels sport a combination of gloss black and matte black paint, with golden highlights.</p><div class="gaadi-after-second-para-desktop" style="margin-left: auto; margin-right: auto; text-align: center; margin-bottom: 10px; " id="gaadi-1201597946"><script type="rocketlazyloadscript" async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-9822732038633821" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-9822732038633821" 
data-ad-slot="1087923335" 
data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript"> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<p><img class="aligncenter size-large wp-image-191509" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20696%20392'%3E%3C/svg%3E" alt="Royal Enfield Interceptor 650 custom Apollo Garage img3" width="696" height="392" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-696x392.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3.jpg 1600w" data-lazy-sizes="(max-width: 696px) 100vw, 696px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1277x720.jpg" /><noscript><img class="aligncenter size-large wp-image-191509" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1277x720.jpg" alt="Royal Enfield Interceptor 650 custom Apollo Garage img3" width="696" height="392" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-696x392.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3.jpg 1600w" sizes="(max-width: 696px) 100vw, 696px" /></noscript></p>
<p>At the front, we also see an aftermarket LED headlight, a new handlebar, a pair of bar-end rear-view mirrors, and a short front fender. The engine cover, crank cover, exhaust, etc., sport a matte black finish, matching the rest of the bike. The tail section of the bike’s frame has been bent upwards slightly, and the rear fender is tiny. We also see a tiny, round aftermarket taillight here, along with a custom single-piece leather seat.</p>
<p>Aftermarket shock absorbers have been added to the rear, along with new exhaust mufflers. The bike also gets 17-inch wire-spoked wheels with an all-black finish, shod with chunky block pattern tyres. To say that the final model looks utterly brilliant and attractive would be an understatement.</p><div class="gaadi-content_3" style="margin-left: auto; margin-right: auto; text-align: center; " id="gaadi-567627124"><script type="rocketlazyloadscript" async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-9822732038633821" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" 
data-ad-client="ca-pub-9822732038633821" 
data-ad-slot="6020685813"></ins> 
<script type="rocketlazyloadscript"> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<p><img class="aligncenter size-large wp-image-191512" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20696%20522'%3E%3C/svg%3E" alt="Royal Enfield Interceptor 650 custom Apollo Garage img6" width="696" height="522" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-960x720.jpg 960w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-667x500.jpg 667w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-100x75.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-696x522.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-1068x801.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-560x420.jpg 560w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-80x60.jpg 80w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-265x198.jpg 265w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6.jpg 1400w" data-lazy-sizes="(max-width: 696px) 100vw, 696px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-960x720.jpg" /><noscript><img class="aligncenter size-large wp-image-191512" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-960x720.jpg" alt="Royal Enfield Interceptor 650 custom Apollo Garage img6" width="696" height="522" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-960x720.jpg 960w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-667x500.jpg 667w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-100x75.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-696x522.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-1068x801.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-560x420.jpg 560w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-80x60.jpg 80w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-265x198.jpg 265w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6.jpg 1400w" sizes="(max-width: 696px) 100vw, 696px" /></noscript></p>
<p>No changes to the powertrain have been reported here. A stock Royal Enfield Interceptor 650 draws power from a 648cc, air/oil-cooled, parallel-twin engine, which generates 47.65 PS and 52 Nm of peak power and torque, respectively. It comes mated to a 6-speed transmission, with a slipper clutch available as standard.</p>
<div id='gallery-1' class='gallery galleryid-191492 gallery-columns-3 gallery-size-thumbnail'><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/royal-enfield-interceptor-650-custom-apollo-garage-img1/'><img width="100" height="56" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2056'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img1" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1.jpg 1600w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-100x56.jpg" /><noscript><img width="100" height="56" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-100x56.jpg" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img1" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1.jpg 1600w" sizes="(max-width: 100px) 100vw, 100px" /></noscript></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/royal-enfield-interceptor-650-custom-apollo-garage-img2/'><img width="100" height="56" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2056'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img2" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2.jpg 1600w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-100x56.jpg" /><noscript><img width="100" height="56" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-100x56.jpg" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img2" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img2.jpg 1600w" sizes="(max-width: 100px) 100vw, 100px" /></noscript></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/royal-enfield-interceptor-650-custom-apollo-garage-img3/'><img width="100" height="56" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2056'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img3" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3.jpg 1600w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-100x56.jpg" /><noscript><img width="100" height="56" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-100x56.jpg" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img3" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img3.jpg 1600w" sizes="(max-width: 100px) 100vw, 100px" /></noscript></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/royal-enfield-interceptor-650-custom-apollo-garage-img4/'><img width="100" height="56" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2056'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img4" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4.jpg 1600w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-100x56.jpg" /><noscript><img width="100" height="56" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-100x56.jpg" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img4" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img4.jpg 1600w" sizes="(max-width: 100px) 100vw, 100px" /></noscript></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/royal-enfield-interceptor-650-custom-apollo-garage-img5/'><img width="100" height="56" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2056'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img5" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5.jpg 1600w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-100x56.jpg" /><noscript><img width="100" height="56" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-100x56.jpg" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img5" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-100x56.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-740x417.jpg 740w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-1277x720.jpg 1277w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-1536x866.jpg 1536w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-696x385.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-1068x602.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5-745x420.jpg 745w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img5.jpg 1600w" sizes="(max-width: 100px) 100vw, 100px" /></noscript></a>
			</div></figure><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/royal-enfield-interceptor-650-custom-apollo-garage-img6/'><img width="100" height="75" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2075'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img6" data-lazy-srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-100x75.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-667x500.jpg 667w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-960x720.jpg 960w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-696x522.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-1068x801.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-560x420.jpg 560w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-80x60.jpg 80w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-265x198.jpg 265w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6.jpg 1400w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-100x75.jpg" /><noscript><img width="100" height="75" src="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-100x75.jpg" class="attachment-thumbnail size-thumbnail" alt="Royal Enfield Interceptor 650 custom Apollo Garage img6" srcset="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-100x75.jpg 100w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-667x500.jpg 667w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-960x720.jpg 960w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-696x522.jpg 696w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-1068x801.jpg 1068w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-560x420.jpg 560w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-80x60.jpg 80w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6-265x198.jpg 265w, https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img6.jpg 1400w" sizes="(max-width: 100px) 100vw, 100px" /></noscript></a>
			</div></figure>
		</div>

<div class="gaadi-after-content" id="gaadi-2069962693"><script type="rocketlazyloadscript" async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-9822732038633821" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-9822732038633821" 
data-ad-slot="3003313883" 
data-ad-format="auto" data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript"> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
 <!-- A generated by theme --> 

<script type="rocketlazyloadscript" async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom tdi_2 td_block_template_1 ">

<style>
/* custom css */
.tdi_2.td-a-rec{
					text-align: center;
				}.tdi_2 .td-element-style{
					z-index: -1;
				}.tdi_2.td-a-rec-img{
				    text-align: left;
				}.tdi_2.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
var td_screen_width = window.innerWidth;
</script>
<noscript id="td-ad-placeholder"></noscript></div>

 <!-- end A --> 

        </div>

        <footer>
            <!-- post pagination -->            <!-- review -->
            <div class="td-post-source-tags">
                <!-- source via -->                <!-- tags -->            </div>

            <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
		<style>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</style>

		<div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fgaadiwaadi.com%2Fheres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand%2F" title="Facebook" >
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Here%E2%80%99s+A+Lovely+Custom+Royal+Enfield+Interceptor+650+From+Thailand&url=https%3A%2F%2Fgaadiwaadi.com%2Fheres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand%2F&via=gaadiwaadi" title="Twitter" >
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Here%E2%80%99s+A+Lovely+Custom+Royal+Enfield+Interceptor+650+From+Thailand %0A%0A https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/" title="WhatsApp" >
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <!-- next prev -->            <!-- author box --><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://gaadiwaadi.com/author/ksitijrawat20/">Kshitij Rawat</a></span></div>            <!-- meta --><span class="td-page-meta"   ><meta  content="Kshitij Rawat"></span><meta  content="2021-12-20T18:42:39+05:30"><meta  content="2021-12-20T18:42:39+05:30"><meta  itemid="https://gaadiwaadi.com/heres-a-lovely-custom-royal-enfield-interceptor-650-from-thailand/"/><span class="td-page-meta"   ><span class="td-page-meta"   ><meta  content="https://gaadiwaadi.com/wp-content/uploads/2018/06/GW-logo.png"></span><meta  content="Gaadiwaadi.com - Latest Car &amp; Bike News"></span><meta  content="Here’s A Lovely Custom Royal Enfield Interceptor 650 From Thailand"><span class="td-page-meta"   ><meta  content="https://gaadiwaadi.com/wp-content/uploads/2021/12/Royal-Enfield-Interceptor-650-custom-Apollo-Garage-img1.jpg"><meta  content="1600"><meta  content="902"></span>        </footer>

    </article> <!-- /.post -->

    
                                </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
        </div> <!-- /.td-container -->
    </div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-14 ">
    <div class="td-container td-footer-bottom-full">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://gaadiwaadi.com/"><img width="300" height="89" src="https://gaadiwaadi.com/wp-content/uploads/2018/06/GW-logo.png" alt="Gaadiwaadi-logo" title=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>GaadiWaadi.com is India’s no. 1 source for latest automotive news managed by Tecnonation Media Pvt Ltd with boot loads of scoops, reviews and trivia written by motoring experts and enthusiasts. Launched in 2013 with the aim of providing unbiased automotive news, views, reviews, comparisons and analysis. We are now the country’s one of the most trusted online automotive news sources.<div class="footer-email-wrap">Contact us: <a href="mailto:contact@gaadiwaadi.com">contact@gaadiwaadi.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/gaadiwaaditimes" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://news.google.com/publications/CAAqBwgKMLyt3gowkeLVAQ?oc=3&ceid=IN:en" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://news.google.com/publications/CAAqBwgKMLyt3gowkeLVAQ?oc=3&ceid=IN:en" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/gaadiwaadidotcom" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-footer-container"><ul id="menu-footer" class="td-subfooter-menu"><li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-536"><a target="_blank" rel="noopener" href="https://gaadiwaadi.com/latest-news/">Latest News</a></li>
<li id="menu-item-5532" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-5532"><a href="https://gaadiwaadi.com/reviews/">Reviews</a></li>
<li id="menu-item-5531" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5531"><a href="https://gaadiwaadi.com/about-us/">About us</a></li>
<li id="menu-item-3691" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3691"><a href="https://gaadiwaadi.com/contact/">Contact us</a></li>
<li id="menu-item-3692" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3692"><a href="https://gaadiwaadi.com/visitors-agreement/">Visitors Agreement</a></li>
<li id="menu-item-3693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-3693"><a href="https://gaadiwaadi.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-39353" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-39353"><a href="https://gaadiwaadi.com/about-us/">Website managed by Tecnonation Media Pvt Ltd</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Copyright 2021 GaadiWaadi.com, (Member of FASTER Organisation) All Rights Reserved                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->


<script type="rocketlazyloadscript">window.advanced_ads_check_adblocker=function(t){var n=[],e=null;function i(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}return i((function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),i((function(){var i=window.getComputedStyle&&window.getComputedStyle(t),o=i&&i.getPropertyValue("-moz-binding");e=i&&"none"===i.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var a=0,r=n.length;a<r;a++)n[a](e);n=[]}))})),function(t){null!==e?t(e):n.push(t)}}();</script>            <style type="text/css">
						.svc_pre_container_after{
				margin-top:2px;
				margin-bottom:2px;
			}
			.svc_pre_container_after .svc_next_content{
				padding:10px 10px 10px 10px;
				background:#ffffff;
			}	
			.svc_pre_container_after .svc_next_ref{border-top: 4px solid #191919;}
			.svc_pre_container_after .svc_next_ref::before{border-top: 10px solid #191919;}
			.svc_pre_container_after .svc_next_ref .svc_next_txt{ color:#0769bf; font-size:20px; line-height:20px;}
			
			</style>
            				<input type="hidden" class="svc_next_url" value="https://gaadiwaadi.com/check-out-indias-first-tata-punch-fitted-with-cng-kit/">
				<input type="hidden" class="svc_next_url_set" value="1">
                                <script type="rocketlazyloadscript">
                	function ads_start_callback(){
                		document.querySelectorAll("script[type=rocketlazyloadscript]").forEach((e => { 
						     const new_script = document.createElement("script");
						      let t = e.nodeName;
						     if( e.hasAttribute("src") ){
						        new_script.addEventListener("load", e);
						        new_script.addEventListener("error", e);
						      }else{
						        new_script.text = e.text;
						        }
						      e.parentNode.replaceChild(new_script, e);



						    var docfrag = document.createDocumentFragment();
							if( e.hasAttribute("src") ){
							     const n = e.getAttribute("src");
							     if (n) {
							        const t = document.createElement("link");
							                t.href = n, t.rel = "preload", t.as = "script", e.appendChild(t)
							     }
							 }

						}))


                	}


											function svc_on_start_callback(){
							console.log('start_callback');
														ads_start_callback();
						}
										function svc_on_end_callback(){
						console.log('end_callback');
												ads_start_callback();
					}
									</script>
			

    <!--

        Theme: Newspaper by tagDiv.com 2021
        Version: 11 (rara)
        Deploy mode: deploy
        
        uid: 61c081635c66c
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
<pre>
@media (max-width: 767px){
.td-header-style-8-wrapper.td-menu-placeholder .td-menu-background, .td-header-style-8 .td-menu-wrap {
  height: 48px !important;
}
.header-search-wrap #search-button .td-sp-ico-search {
  top: 1px !important;
}

   

}
             /*  2-jul-15  */
.td-main-page-wrap {
  padding-top:10px;
  /* responsive portrait phone */
}

.td-header-wrap .td-header-menu-wrap-full, .td-header-wrap .td-header-menu-wrap, .td-header-wrap .td-header-main-menu {
    background-color: #f4f4f4 !important;

}

#td-top-mobile-toggle i {
color:#000;
}
.header-search-wrap .td-icon-search {
  color: #000 !important;
}
body .td-page-title {
display:none;
}

</pre> 
</style>

<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/cache/min/1/wp-content/plugins/fluid-width-wrapper-remover/js/fluid_wrapper_remover.js?ver=1639849454' id='fwr-jslib-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.15.0' id='advanced-ads-pro/front-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=45456ad3a6d583e9cee0a9fe2cdd86cb' id='tdb_js_posts_autoload-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11' id='td-site-min-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=45456ad3a6d583e9cee0a9fe2cdd86cb' id='tdb_js_files_for_front-js' defer></script>
<script type='text/javascript' src='https://gaadiwaadi.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/cache/min/1/sdks/OneSignalSDK.js?ver=1639849454' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' id='next-post-js-js-extra'>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</script>
<script type="rocketlazyloadscript" data-minify="1" data-rocket-type='text/javascript' src='https://gaadiwaadi.com/wp-content/cache/min/1/wp-content/plugins/wp-next-post/assets/js/next-post-script.js?ver=1639849454' id='next-post-js-js' defer></script>
<!--noptimize--><script type="rocketlazyloadscript">window.advads_admin_bar_items = [{"title":"After Featured Image Desktop Web","type":"ad"},{"title":"Before Content 2","type":"placement"},{"title":"After 3rd Para desktop","type":"ad"},{"title":"After Second Para Desktop","type":"placement"},{"title":"After 5th Para Desktop","type":"ad"},{"title":"Content 3","type":"placement"},{"title":"After content desktop","type":"ad"},{"title":"After Content","type":"placement"}];</script><!--/noptimize--><!--noptimize--><script type="rocketlazyloadscript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><!--/noptimize-->
<!-- JS generated by theme -->

<script type="rocketlazyloadscript">window.addEventListener('DOMContentLoaded', function() {
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[191492]");
                });
            
});</script>

<script type="rocketlazyloadscript" src='https://stats.wp.com/e-202151.js' defer></script>
<script type="rocketlazyloadscript">
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4',blog:'92957650',post:'191492',tz:'5.5',srv:'gaadiwaadi.com'} ]);
	_stq.push([ 'clickTrackerInit', '92957650', '191492' ]);
</script>
    <script type="rocketlazyloadscript" data-rocket-type="text/javascript">window.addEventListener('DOMContentLoaded', function() {
        jQuery(document).ready(function ($) {

            for (let i = 0; i < document.forms.length; ++i) {
                let form = document.forms[i];
				if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="KdIUbxrvMCG" value="154jJ." />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="RtZfNJOKYaVA" value="JM7jG0pZY5_" />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="FhyUwClGsAqp" value="aPueOq90KCJZAbm" />'); }
            }

            $(document).on('submit', 'form', function () {
				if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="KdIUbxrvMCG" value="154jJ." />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="RtZfNJOKYaVA" value="JM7jG0pZY5_" />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="FhyUwClGsAqp" value="aPueOq90KCJZAbm" />'); }
                return true;
            });

            jQuery.ajaxSetup({
                beforeSend: function (e, data) {

                    if (data.type !== 'POST') return;

                    if (typeof data.data === 'object' && data.data !== null) {
						data.data.append("KdIUbxrvMCG", "154jJ.");
data.data.append("RtZfNJOKYaVA", "JM7jG0pZY5_");
data.data.append("FhyUwClGsAqp", "aPueOq90KCJZAbm");
                    }
                    else {
                        data.data = data.data + '&KdIUbxrvMCG=154jJ.&RtZfNJOKYaVA=JM7jG0pZY5_&FhyUwClGsAqp=aPueOq90KCJZAbm';
                    }
                }
            });

        });
    });</script>
	<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://gaadiwaadi.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script type="rocketlazyloadscript">"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel="stylesheet" href="https://gaadiwaadi.com/wp-content/cache/min/1/af07065d0eab9e6ec615a5c0bfb88fc7.css" media="all" data-minify="1" /><link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=11' type='text/css' media='all' /></noscript></body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1640005989 -->